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Building your computer list

The computer list is the left panel of the main window. It holds the machines you send to, arranged into

groups, with a search box at the top and a status indicator on each entry. You can build it by hand, enter

name patterns, or pull machines from a source such as Active Directory or an IP range.

Start with the computer list itself, then fill it: add a computer by hand, add multiple computers from a name

pattern, or add computers from a source such as Active Directory or an IP range. From there you can sort

machines into groups, tidy a large list with bulk operations, keep an eye on computer status, search and

filter to narrow it down, and import or export the list to reuse it elsewhere.

Once the list is in place, you select recipients with the checkboxes and move on to sending messages. For a

task-focused walkthrough, see the how-to on building a computer list for LAN messaging. You can also

download LanSend if you have not installed it yet.

The computer list

The computer list fills the left panel of the main window. It holds the machines you message, organized into

groups, with a status indicator on each entry and a search box at the top.

https://lizardsystems.com/lansend/how-to/how-to-build-a-computer-list-for-lan-messaging/
https://lizardsystems.com/download/lansend/
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What the panel shows

The list is a tree, so you can sort machines into groups and nest groups inside other groups. Each entry is

one computer.

A status indicator next to each computer shows whether it is online. LanSend checks state with a periodic

Ping or a TCP connect to port, and you can turn the check off. Set this on the General page of File >

Preferences.... To refresh the state right away, use Computers > Update computers.

Each entry shows its computer name, its description, or a combination of the two. The Show computer

caption as setting on the Computer list page of Preferences offers four options: Computer name

(Description), Description (Computer name), Computer name, and Description. By default it is set to

Computer name (Description), so each entry shows the name with the description in parentheses.

Open and save a list

The list lives in a file, and the File menu manages it:

• New starts an empty list.

• Open loads a saved list.

• Save writes the current list back to its file.

• Save as... writes it to a new file.

List files are stored as JSON or XML.
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Find a computer

The search box at the top of the panel filters the list as you type, matching both the name and the

description. Clear the box to show every computer again. For more on narrowing a long list, see Search and

filter.

Select who gets the message

Each computer has a checkbox. The computers you check are the recipients, and their names appear in the

recipients box (marked with a person icon) at the top of the composer. To set the whole list at once, use the

Computers menu:

• Check all selects every computer.

• Uncheck all clears the selection.

• Inverse flips the selection. It checks what was unchecked and clears what was checked.

How the checked computers become recipients is covered in Choosing recipients.

See also

• Add a computer

• Search and filter

• Choosing recipients

• LanSend

Add a computer

Computers > Add computer puts one machine on the list. Use it when you want to add a single computer

by name rather than pasting a batch or pulling them from a source.

https://lizardsystems.com/lansend/
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How to do it

1. Open Computers > Add computer.

2. In Computer name or IP address, type the machine's name or IP address, or click the browse button

(...) to pick one.

3. Add a Description if you want one. This field is optional.

4. Use the Notes tab to keep any longer notes with the entry.

5. Confirm to add the machine to the list.

LanSend does not store per-computer credentials, so there is no Credentials tab. To message a machine

you need network reachability to it plus administrative rights on it.

Edit or remove an entry

• Computers > Edit changes the selected entry, so you can fix a name or update its description.

• Computers > Delete removes the selected entry.

• Computers > Delete all clears the whole list.

To add several machines at once instead of one at a time, use Add multiple computers. Once entries are on

the list, you can sort them into Groups.

See also

• Add multiple computers

• Groups

• LanSend

Add multiple computers

When you want to add a run of machines that share a naming scheme, Computers > Add multiple

computers... lets you enter a name pattern that expands into many names at once. It is the quick way to

seed a list. New in 26.06.

https://lizardsystems.com/lansend/
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How to do it

1. Select the group you want to fill, or create one first.

2. Open Computers > Add multiple computers....

3. In Computer name pattern, enter a name pattern that expands into multiple names, such as

server[01-10].

4. Check the preview, which lists the names that will be added as you type.

5. Set the group name if you want them in a different group.

6. Confirm to add the names to the group.

Pattern examples

The pattern field expands into a list of names:

• server[01-10] makes server01 through server10.

• [1-10:2] steps the numbers by 2, so 1, 3, 5, 7, and 9.

• {srv-a,srv-b} gives the exact names you list inside the braces.

• [A-Z] runs through a letter range.

• [A-C][1-3] combines parts, so A1, A2, A3, B1, and so on.



LanSend - LanSend handbook

To add a specific set of names rather than a run, list them with the brace syntax, like

{mars,venus,pluto}. There is no plain one-name-per-line box, so everything comes from the pattern

and the preview shows exactly what will be added.

The names go into the group you picked, so you can keep one set of machines separate from another. To

pull machines from a source instead of building names from a pattern, use Add computers from....

See also

• Add computers from...

• How to build a computer list

• LanSend

Add computers from...

Add computers from... is a wizard that pulls machines into your list from a source instead of you typing

names. It is the renamed Add computers wizard from earlier versions.

How to do it

1. Choose Computers > Add computers from....

https://lizardsystems.com/lansend/how-to/how-to-build-a-computer-list-for-lan-messaging/
https://lizardsystems.com/lansend/
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2. Pick a source. IP Range is selected by default.

3. Let the wizard find the machines for that source, then finish to add them to your list.

Sources

• Network reads computers visible on the local network.

• Active Directory reads computer accounts from an Active Directory domain.

• IP Range scans a range of IP addresses. This is the default selection.

• Hyper-V reads virtual machines from a Hyper-V host.

• RDS reads hosts from Remote Desktop Services.

• SCCM reads machines from System Center Configuration Manager.

• WSUS reads machines from Windows Server Update Services.

If you only have a handful of names to enter, add multiple computers by listing them as a name pattern

instead, for example the brace list {mars,venus,pluto}. Either way, you can sort the results into groups

afterward.

See also

• Add multiple computers

• Groups

• Download LanSend

Groups

Groups let you organize the computers in your list into a folder-style tree, so a department, a floor, or a site

stays together. Once a group exists, you can message everyone in it in one action instead of picking

machines one by one.

https://lizardsystems.com/download/lansend/
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Create a group

Choose Computers > Create new group and type a name. Groups are hierarchical, so you can nest one

group inside another to mirror how your network is laid out, for example a site group with a group per floor

underneath it.

Reorganize the list

Drag entries to move them. Pull a computer into a group, or drop a group inside another group, by dragging

it where you want it. The tree updates as you go, so you can shape the list without retyping any names.

Expand and collapse

When the tree gets deep, Computers > Expand all groups opens every group at once and Computers >

Collapse all groups closes them back down. Use collapse to get a tidy top-level view, expand when you

need to see every machine.

Send to a whole group

To message a group, check its box in the list, and the message goes to every computer inside it. The group

name then appears in the recipients box at the top of the composer. See Choosing recipients for the ways to

pick who receives a message.

See also

• Bulk operations

• Choosing recipients

• LanSend

Bulk operations

Bulk operations apply one change across the whole computer list at once, so you can tidy a large list

without editing entries one at a time. It is new in 26.06.

https://lizardsystems.com/lansend/
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How to do it

1. Choose Computers > Bulk operations....

2. In the Bulk operations dialog, pick the operation you want.

3. Set any criteria the operation offers, then apply it to the list.

Operations

• Remove inactive computers drops machines that are not responding to the status check.

• Remove duplicate computers keeps one entry per machine and removes the repeats.

• Remove empty groups deletes groups that hold no computers.

• Remove by pattern removes entries whose name matches a pattern you supply.

• Flatten group structure moves every computer up to a single level and clears the nesting.

• Normalize computer names rewrites names to a consistent case: UPPERCASE, lowercase, or Title

Case.

• Rename computers changes names across the list in one pass.

• Group computers sorts the list into groups by name prefix, subnet, or domain.

• Format descriptions applies a consistent format to the description text on each entry.
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Bulk operations work on the whole list, so they pair well with groups: regroup or flatten first, then send to a

group in one action. For an overview of how the list fits together, see The computer list.

See also

• The computer list

• Groups

• How to build a computer list

• LanSend

Checking computer status

LanSend can mark each computer on your list as online or offline so you know which machines are

reachable before you send. You choose how it checks, or turn the check off, on the General preferences

page.

How the status check works

The check runs periodically against every computer in the computer list. On the General page of File >

Preferences..., the Check state group sets the method:

• Don't check state turns the check off. No computer shows an online or offline state.

• Ping sends an ICMP echo to each machine.

• TCP connect to port opens a connection to a port instead. The port field next to it defaults to 139.

A Timeout value, in milliseconds, decides how long LanSend waits for a reply before it counts a machine as

offline. The Threads value sets how many computers are checked at once.

https://lizardsystems.com/lansend/how-to/how-to-build-a-computer-list-for-lan-messaging/
https://lizardsystems.com/lansend/
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Refresh the status now

To check every machine again without waiting for the next round, choose Computers > Update

computers. The list updates with the current online and offline states.

You can also have the list refresh on its own. On the Computer list preferences page, Automatically

update computer list turns on a repeating refresh, with an Update interval in seconds.

Show reachable machines first

On the same Computer list page, turn on Show online computers before offline ones to sort the

reachable machines to the top of the list. Offline machines drop to the bottom, so the computers you can

message are together.

See also

• General preferences

• The computer list

• LanSend

Search and filter

The search box above the computer list filters the tree as you type. It matches both the name and the

description. Pair it with the selection commands to pick a subset of machines before you send.

https://lizardsystems.com/lansend/
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Search the list

Type into the search box at the top of the left panel. The list narrows to the computers whose name or

description matches what you typed, and updates with each keystroke. Clear the box to show the full list

again.

Select a subset

Once the list shows the machines you want, set their checkboxes. Three commands on the Computers

menu speed this up:

• Check all ticks every computer in the list, including any currently hidden by the search filter.

• Uncheck all clears every checkbox.

• Inverse flips the current selection, so checked becomes unchecked and the rest become checked.

Note: Check all, Uncheck all, and Inverse act on the whole list, not just the computers the search is

currently showing, and a computer stays checked even after the search hides it. To send to only the

machines that match a search, tick those rows yourself rather than using Check all - otherwise you will send

to every computer in the list.

See also

• The computer list

• Choosing recipients

• LanSend

Import and export

Export writes your computer list to a file, and import reads one back in. Use them to copy a list to another

machine or to hand it to a colleague, without rebuilding the groups by hand.

https://lizardsystems.com/lansend/
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Export the list

Choose Computers > Export, pick a format, and save the file. The export holds the computers and groups

as they appear in the tree.

Import a list

Choose Computers > Import and open a file. The machines and groups it contains are added to the current

list.

Formats

Import and export support four formats:

• JSON

• XML

• Text (.txt)

• RHF (deprecated, kept for older files)

There is no CSV.

The list file you work with through File > New, Open, Save, and Save as... is separate from import and

export, and it uses JSON or XML only. Reach for import and export when you want to move computers in or

out of a list rather than open a whole list as your working file.
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See also

• The computer list

• LanSend

https://lizardsystems.com/lansend/
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Sending messages

You compose a message in the upper-right panel of the main window. Pick the recipients in the computer

list, choose a message type and title, type the body, and send. A few controls let you fine-tune who sees the

message and for how long.

The job breaks down into a few steps: composing the message, setting its message type and title, choosing

recipients, picking the session scope, adding an auto-close timeout, previewing it first, and dropping in

variables that fill in automatically.

The message goes out over the built-in Windows messaging channel, so recipients see a standard pop-up

with no extra software. To send to everyone at once, see send a message to all computers on the network;

to reach a single machine, see send a message to a specific computer. You can save any message you

compose for later as a preset.

Compose a message

You build a message in the upper-right panel of the main window: choose who gets it, set its type, give it a

title, type the body, and send. The message goes out over the built-in Windows Terminal Services channel,

so nothing is installed on the recipient.

https://lizardsystems.com/lansend/how-to/how-to-send-a-message-to-all-computers-on-the-network/
https://lizardsystems.com/lansend/how-to/how-to-send-a-message-to-a-specific-computer-on-the-lan/
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Write and send

1. In the computer list on the left, check the boxes for the machines or groups you want to reach. The

recipients box at the top of the composer (marked with a person icon) shows who is selected.

2. Pick a message type and title: open the type combo and choose None, Info, Warning, or Error, then

type a title.

3. Type the body in the message memo.

4. Click Send message.

The body and title can include variables, and you can start from a saved preset instead of typing from

scratch.

The composer fields

• The recipients box (marked with a person icon) lists the recipients you checked in the computer list.

• The message type combo sets the icon and sound: None has no icon, while Info, Warning, and Error

each carry the matching Windows icon and sound.

• The title field holds a short headline for the pop-up.

• The body memo holds the message text.

• The presets button (the menu icon next to the message body) fills the title, body, and type from a saved

message.

Use variables in the text

The title and body accept five variables, written between percent signs. They are case-insensitive and

expand just before the message is sent, resolving to the values on your own machine:
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• %computer_name%

• %user_name%

• %time_now% (date and time)

• %time%

• %date%

For example, Save your work, %computer_name% restarts soon sends with the sender's

computer name in place.

See also

• Message type and title

• How to send a message to all computers

• LanSend

Message type and title

The message type sets the icon and sound the recipient sees and hears, and the title becomes the heading

of the pop-up. Both sit at the top of the composer, above the message body.

Pick a message type

The type combo has four choices:

• None sends a plain message with no icon.

• Info adds the Windows information icon and sound.

• Warning adds the Windows warning icon and sound.

https://lizardsystems.com/lansend/how-to/how-to-send-a-message-to-all-computers-on-the-network/
https://lizardsystems.com/lansend/
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• Error adds the Windows error icon and sound.

The icon and sound tell the recipient how urgent the message is before they read a word. Use Info for

routine notices, Warning when someone needs to act soon, such as saving work before a restart, and Error

for a problem that is already affecting them. Pick None when an icon would be a distraction.

Set the title

The title field is the heading of the message box on the recipient's screen, shown above the body text. Keep

it short and specific so the point is clear at a glance, for example "Server restart at 6 PM" rather than

"Notice".

A title is optional. If you leave it empty, the pop-up shows only the body text.

See also

• Choosing recipients

• Preview a message

• LanSend

Choosing recipients

Before you send, you decide which machines get the message. You pick recipients in the computer list on

the left, and the recipients box (marked with a person icon) at the top of the composer shows your current

selection.

https://lizardsystems.com/lansend/
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Tick the computers or groups

Each item in the list has a checkbox. Tick a computer to add it, or tick a group to include every computer in

it. As you check and uncheck items, the recipients box at the top of the composer updates to reflect the

selection.

To change the whole list at once, use the Computers menu:

• Check all selects every computer in the list.

• Uncheck all clears the selection.

• Inverse flips it, so checked items become unchecked and the rest become checked.

Narrow the list first

When the list is long, type in the search box at the top of the computer panel. It filters the list as you type and

matches both the name and the description, so you can find a machine or trim the view down to the ones

you want before you tick them. For more on organizing and adding machines, see Building your computer

list.

Set the session scope

The Sessions: dropdown on the send bar controls which sessions on each recipient receive the message:

All sessions, Active, Logged-on, or Console. Set this when more than one user may be signed in to a

machine. See Session scope for what each option means.

See also

• Session scope

• Building your computer list

• LanSend

Session scope

A Windows PC can run several sessions at once: one person at the keyboard, others connected over

Remote Desktop, plus sessions that are signed in but disconnected. The "Sessions:" dropdown on the

send bar picks which of those receive your message. New in 26.06.

https://lizardsystems.com/lansend/
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Pick a scope before you send

The "Sessions:" dropdown sits at the right-hand end of the send bar. Choose one of four options, then

send. The same scope applies to every computer in the send.

• All sessions delivers to every session on the computer.

• Active reaches the session that is currently active or interactive, whether local or over Remote Desktop.

• Logged-on covers active sessions plus disconnected ones.

• Console delivers to the physical console session only.

When to use each

• Use Active for a quick note to whoever is using the machine right now. A disconnected session is

skipped, but a locked session still counts as active.

• Use Logged-on when you want everyone who is signed in to see the message, including a person who

connected over Remote Desktop and then disconnected without signing off. It is the broadest practical

choice for reaching real people.

• Use Console to target the screen physically attached to the computer, ignoring any remote sessions.

• Use All sessions when the message should land in every session regardless of state.

The scope you pick here works the same way whether you send to one computer or to a whole group, so it

pairs naturally with sending to many machines at once.

See also

• Compose a message

• How to send a message to all computers

https://lizardsystems.com/lansend/how-to/how-to-send-a-message-to-all-computers-on-the-network/
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• LanSend

Auto-close timeout

The Close message after checkbox, in the send bar at the bottom of the window, dismisses your message

on the recipient's screen after a set time. Leave it unticked and the message stays up until the person clicks

OK.

How to set it

1. Tick Close message after.

2. Type a value from 1 to 60.

3. Pick the unit: seconds, minutes, or hours.

4. Send the message as usual with Send message.

The countdown runs on each recipient's machine. When it reaches zero, the message box closes by itself,

whether or not anyone has read it.

When a timeout helps

A short timeout suits a quick notice that does not need a reply, such as a reminder that stops cluttering the

screen on its own. It also clears messages on machines where no one is watching, so an unattended PC is

not left with a dialog open.

Leave Close message after unticked when the recipient must see and acknowledge the message, for

example a shutdown warning. With no timeout, the message waits until the user clicks OK.

See also

• Preview a message

• Session scope

• LanSend

Preview a message

Message > Preview message shows the message box on your own screen first, with the same type, title,

and timeout you have set. Use it to check how a message reads before it goes out to anyone.

https://lizardsystems.com/lansend/
https://lizardsystems.com/lansend/
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How to preview

1. Write the message in the composer: pick a Message type, set the title, and type the body.

2. Open Message > Preview message, or use the preview action in the composer.

3. The pop-up appears on your own screen, exactly as a recipient would see it.

4. Click OK to close the preview, then adjust the message or send it.

The preview is available once the body has text. With no body, there is nothing to show.

What the preview matches

The preview uses the same settings as the real message:

• Message type sets the icon and sound. None has no icon; Info, Warning, and Error each carry the

matching Windows icon and sound.

• The title and body show as typed.

• The Close message after timeout applies. If the checkbox is ticked, the preview closes on its own after

the set time; if not, it stays until you click OK.

One thing to note: variables such as %computer_name% and %user_name% resolve to your own local

values in the preview, since they always expand to the sender's values just before sending.

See also

• Compose a message

• Variables

• LanSend

Variables

Variables are placeholders you type into a message title or body. LanSend replaces each one with a value

from your own computer just before the message is sent.

https://lizardsystems.com/lansend/
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The five variables

There are five variables. Names are case-insensitive, so %COMPUTER_NAME% works the same as

%computer_name%.

Variable Expands to
%computer_name% The name of your computer
%user_name% The user signed in to your computer
%time_now% The current date and time
%time% The current time
%date% The current date

Each one resolves to the local value on the sending machine, not on the recipient. So %computer_name%

is the name of the PC you are sending from, and %user_name% is the account you are signed in with.

When they expand

LanSend keeps the text as you typed it, with the %...% markers intact, until you send. The values are filled

in at that moment, so the date and time match when the message actually goes out. You can use variables

in the title, the body, or both.

An example

Type a message like this:

• Title: Maintenance on %computer_name%

• Body: Sent by %user_name% at %time_now%. Please save your work.
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Sent from a PC named SALES-01 signed in as jsmith, the recipient sees the title Maintenance on

SALES-01 and a body that starts Sent by jsmith at followed by the current date and time.

The same five variables work in the title and body passed on the command line.

See also

• Message type and title

• Command line

• LanSend

https://lizardsystems.com/lansend/
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Message presets

A preset is a saved message: a name, a title, a body, and a message type, kept in a category so you can

find it quickly. Presets turn the messages you send often, such as a maintenance notice or an emergency

alert, into a one-click starting point.

Open the Presets menu, or the presets button (the menu icon next to the message body), to load one by

category. LanSend ships a default set you can use straight away, and you can save any message you

compose with Message > Add message to presets. For a worked example, see warn users before a

reboot or maintenance.

This part covers using presets to load and send one, the Presets menu and its import, export, and reset

commands, how to manage presets and categories, and the default preset categories LanSend ships with.

Using presets

A preset is a saved message with a name, title, body, and type, kept in a category. Loading one is the

fastest way to send a message you use often.

Load a preset

1. Open the Presets menu, or click the presets button (the menu icon next to the message body).

https://lizardsystems.com/lansend/how-to/how-to-warn-users-before-a-reboot-or-maintenance/
https://lizardsystems.com/lansend/how-to/how-to-warn-users-before-a-reboot-or-maintenance/
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2. Pick a preset from its category. LanSend fills the title, the body, and the message type from the saved

message.

3. Adjust the wording if you need to, pick your recipients, then click Send message.

The preset only fills in the message fields. The recipients you have checked, the Sessions: scope, and the

Close message after timeout stay as you set them, so the same preset works for any list of computers.

Where presets come from

LanSend ships with default categories such as Maintenance & Updates, Emergency & Critical, Service

Notifications, and Testing & System Check, with ready-made messages like Save Your Work, Scheduled

Maintenance, and Emergency Shutdown. Presets you made in earlier versions carry over when you

upgrade, and the defaults are restored if any are missing.

See also

• The Presets menu

• How to warn users before a reboot

• LanSend

The Presets menu

The Presets menu and the presets button (the menu icon next to the message body) both open your saved

messages, grouped by category. The menu also holds the commands to import, export, manage, and reset

your presets. Categories are new in 26.06.

Load a preset

Open the Presets menu, or click the presets button in the composer, then pick a preset from its category.

LanSend fills the title, body, and message type from the saved message, and leaves your recipients and

send options as you set them. For the full walkthrough, see Using presets.

Menu commands

Below the categories, the Presets menu has four commands:

https://lizardsystems.com/lansend/how-to/how-to-warn-users-before-a-reboot-or-maintenance/
https://lizardsystems.com/lansend/
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• Import presets adds presets from a file, so you can bring in a set from another machine.

• Export presets writes your presets to a file to share or keep as a backup.

• Reset to defaults restores the default categories and presets.

• Manage presets opens the category and preset tree, where you add, edit, move, or delete presets and

categories. See Manage presets.

See also

• Default preset categories

• LanSend

Manage presets

Presets are saved messages you can load in one click. The Manage presets window is where you build

and rearrange them.

Open the manager

Choose Message > Manage presets. A tree opens with your categories and the presets inside each one.

From here you can add, edit, move, or delete both presets and categories.

https://lizardsystems.com/lansend/
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Add, edit, and delete

The buttons to the right of the tree manage its contents:

• Add category creates a new category, and Add item adds a preset to the selected category.

• Edit opens the selected preset in the Edit preset dialog (it reads Create preset for a new one), with four

fields: Preset name, Title, Message type, and Message.

• Remove deletes the selected preset or category.

• Up and Down reorder the selected entry, so you can put the presets you use most at the top of a

category.

Save the current message

If you have a message ready in the composer, choose Message > Add message to presets. A Create

preset dialog opens, pre-filled with the current title, body, and message type, with the name left empty. Type

a preset name and click OK, and the preset is saved into the first category. You can move it to another

category later from Manage presets.

See also

• The Presets menu

• Default preset categories

• LanSend

https://lizardsystems.com/lansend/
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Default preset categories

LanSend comes with 15 ready-made presets, sorted into four categories. They cover the messages admins

send most often, so you can load one and adjust the wording instead of starting from a blank message.

The categories

Each category groups presets by the kind of message they carry. Open the Presets menu, or the presets

button (the menu icon next to the message body), to load any of them.

Category Presets Examples

Maintenance & Updates 7

Save Your Work, Scheduled

Maintenance, Planned Server

Restart

Emergency & Critical 3
Emergency Shutdown, Power

Failure Warning

Service Notifications 4
System Restored, Email Service

Disruption

Testing & System Check 1 Test Message

That is 15 presets across the four categories. Load one and it fills the title, body, and type, so the most you

have to do is tweak a date or a name before you send.
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Restoring the defaults

Presets you made in earlier versions carry over when you upgrade, so your own messages stay put. If you

ever clear out every preset, LanSend brings the full default set back automatically the next time it starts. To

restore the defaults at any time, use Reset to defaults in the Presets menu - it replaces all current presets

and categories with the originals.

See also

• Using presets

• How to warn users before a reboot

• LanSend
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Message history

The Message History tab, in the lower-right panel, keeps a record of the messages you have sent. Use it to

confirm a message went out, to send the same thing again, or to turn a one-off message into a saved

preset.

What the list shows

Each row has five columns: Time, Type, Recipients, Title, and Message. The history is stored on your

machine, so it stays available between sessions.

Find a past message

A search box filters the list by text, and the message-type buttons (None, Info, Warning, Error) narrow it to

one type. A status line shows how many of the total rows match the current filter.

What you can do with a row

Right-click a row for its actions:

• Reuse message loads the message back into the composer so you can send it again or adjust it first.

• Add to presets saves it as a preset for later.

• Copy puts the selected rows on the clipboard; Copy all copies the whole list.

• Clear message history empties the list and asks you to confirm first.

See also

• Sending messages

• Message presets

• LanSend

https://lizardsystems.com/lansend/
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Application log

The Application log tab, in the lower-right panel, records what LanSend does as you work: messages sent,

status checks, and any problems it runs into. It is the first place to look when something does not behave as

expected.

What the list shows

Each row has four columns: Time, Level, Category, and Message. Levels run from Debug through Info,

Warning, Error, and Fatal.

Narrow the log

A search box filters by text, the level buttons limit the list to the levels you care about, and the Category

dropdown filters to one area of the program. A status line shows how many of the total entries match.

Copy, export, or clear

• Copy row and Copy all rows put rows on the clipboard, and Copy cell copies a single cell.

• Export to file... saves the currently shown rows as CSV, JSON, or text.

• Clear log clears the entries shown here after you confirm. If file logging is on, the log file is not affected.

To control how much the log records, and to write it to a file as well, see the Logging preferences.

See also

• Logging preferences

• LanSend
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Preferences

Open File > Preferences... to reach the settings dialog. It has a sidebar with five pages, each covering one

area of the program. Defaults are sensible, so you can leave most of it alone and change only what you

need.

The pages are General (how computer status is checked, the default timeout, and how many machines are

messaged at once), Computer list (how the list looks and refreshes), Appearance (light and dark themes),

Logging (the application log and optional file logging), and Updates (how LanSend checks for and installs

new versions).

General

The General page holds the startup behavior and the settings that control how LanSend checks whether a

computer is online. Open it from File > Preferences..., then pick General in the list of pages.
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Startup

The checkbox At startup don't show Wizard if computer list is empty controls whether the Add

computers wizard opens at startup when your computer list is empty.

Check state

This group decides how LanSend tests whether each computer is reachable. Pick one of the three radios:

• Don't check state turns the status check off. No computer is probed and the list shows no online or

offline marks.

• Ping sends an ICMP echo to each computer.

• TCP connect to port opens a connection to the port in the field next to it. The default port is 139.

The result sets each computer's online or offline state in the list. How that state shows, and whether offline

computers sort last, is on the Computer list preferences page. For more on what these marks mean and

when LanSend refreshes them, see Checking computer status.

Timeout

Timeout is how long, in milliseconds, LanSend waits for a single status check to answer before it counts

that computer as offline. A short timeout finishes the scan faster but can mark a slow host offline. Raise it if

computers on a busy or distant network show offline when they are up.
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Threads

Threads sets how many computers LanSend messages at once. A higher value works through a large list

faster. A lower value puts less load on your machine and the network.

See also

• Computer list preferences

• Checking computer status

• LanSend

Computer list

The Computer list page in Preferences controls how each entry in the left panel reads and how often the

list refreshes. Open it from File > Preferences... and select Computer list from the list of pages.

Options

• Show computer caption as sets the label for each entry. Choose Computer name (Description) (the

default) to show the machine name with its description in parentheses, Description (Computer name)

to lead with the description, Computer name to show only the machine name, or Description to show

only the description you typed when you added it.

• Show online computers before offline ones sorts reachable machines to the top of each group.

https://lizardsystems.com/lansend/
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• Automatically update computer list refreshes the status of every entry on a timer. When it is on, set

Update interval in seconds to control how often the refresh runs.

See also

• The computer list

• Appearance preferences

• LanSend

Appearance

The Appearance page in File > Preferences... controls how LanSend looks. You can follow your Windows

light or dark setting, or lock the program to one of them, and choose which theme is used for each.

How to set it

1. Open File > Preferences... and select the Appearance page.

2. Under Appearance mode, pick how LanSend decides between light and dark.

3. Choose a Light theme and a Dark theme from the two pickers.

4. The window updates as you change the settings.

The same choices are on the View > Appearance menu, so you can switch the look without opening

Preferences.

https://lizardsystems.com/lansend/
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Options

• Appearance mode sets when each theme is used:

• Automatic (follow system settings) matches whatever Windows is set to and switches with it.

• Always dark keeps the dark theme regardless of the Windows setting.

Always light keeps the light theme regardless of the Windows setting.

Light theme is the theme used in light mode.

• Dark theme is the theme used in dark mode.

Toolbar and menu icons are vector graphics, so they stay sharp on high-resolution screens and match the

active theme.

See also

• Logging preferences

• The main window

• LanSend

Logging

The Logging page in File > Preferences... controls how much LanSend records and whether it also writes

a log file to disk. File logging keeps a record after you close the app, which helps when you need to look

back at a delivery problem or hand details to support.

https://lizardsystems.com/lansend/help/getting-started/the-main-window/
https://lizardsystems.com/lansend/
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In-app log

Minimum level sets the lowest level that appears in the Application log tab. Anything below the level you

pick is dropped. Raise it to cut noise, lower it to capture more detail while you track down an issue.

File logging

Tick Enable file logging to also write the log to disk. The file gets its own minimum level, separate from the

in-app log, so you can keep the tab quiet but still save full detail to a file.

The remaining fields control the file itself:

• Log path is the folder where log files are written.

• File prefix is the start of each log file's name.

• File format is the layout of the file: CSV, Text, or JSON.

• Max file size is the size in MB at which the current file is closed and a new one starts.

• Max files count is how many log files are kept. Once the limit is reached, the oldest file is removed as a

new one is created.

See also

• Application log

• Updates preferences
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• LanSend

Updates

The Updates page, in File > Preferences..., controls when LanSend checks for a new version and how it

installs one.

Update mode

Pick how LanSend handles an available update:

• Automatic - download and install updates automatically downloads each update and installs it on its

own.

• Download - download automatically, ask before installing is the default. LanSend fetches the

update, then waits for you to confirm the install.

• Notify - only show notification when update available tells you an update exists and leaves the

download and install to you.

• Manual - never check automatically turns off background checks. You check yourself with Check now.

Check frequency

Set how often LanSend looks for a new version: On startup, Daily, Weekly, or Monthly. The default is

Weekly.

https://lizardsystems.com/lansend/
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Version and status

The page shows your Current version, the Last check, and the Next check. Check now runs a check

right away, whatever the mode.

Downloads are verified for authenticity and integrity before they install.

See also

• Checking for updates

• Appearance preferences

• LanSend
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Command line

LanSend can send a message from the command line, which is handy for scripts and scheduled tasks. Pass

the recipients and the message as switches, and LanSend sends without opening its window.

The switches

Attach each value to its switch (an optional colon separates them). A space between the switch and the

value is not read, so write -to:PC1, not -to PC1.

Switch What it sets

-to:
Recipients: computer or group names, separated by

commas. Required.
-title: The message title.

-message:
The message body, or a path to a text file to read it

from. Required.

-type:
Info, Warning, or Error. Leave it off for a plain

message.

-time:
Auto-close timeout in seconds. 0, or omitted, leaves

the message open until the user closes it.

Example

lansend.exe -to:PC1,PC2 -title:Reboot -message:"Save your work, %computer_name% restarts soon" -type:Warning -time:30

To send a longer message, point -message: at a text file:

lansend.exe -to:Sales -message:C:\notices\maintenance.txt -type:Info

The title and body support the same variables as the main window, such as %computer_name% and 

%time%. To run a message on a schedule, create a Windows scheduled task that calls lansend.exe with
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these switches. For a full walkthrough, see send a network message from the command line.

See also

• Variables

• Sending messages

• LanSend
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Updates and licensing

This section covers two housekeeping tasks: keeping LanSend up to date and registering your license. Both

take a minute and you rarely need to repeat them.

LanSend can check for updates on its own or wait for you, and it verifies each download before installing it.

You register LanSend with a license key from the Help menu. To buy a key, see the LanSend purchase

page.

Checking for updates

LanSend can look for new versions on its own and download them in the background. You decide how that

works on the Updates page in Preferences, and you can run a check yourself whenever you want.

https://lizardsystems.com/purchase/lansend/
https://lizardsystems.com/purchase/lansend/
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Check now

There are two ways to start a check by hand:

• Open Help > Check for updates.

• Open File > Preferences..., go to the Updates page, and click Check now.

The Updates page also shows Current version, Last check, and Next check, so you can see which build

you are on and when the next automatic check is due.

Choose how updates are handled

On the Updates page, Update mode has four settings:

• Automatic - download and install updates automatically installs new versions without asking.

• Download - download automatically, ask before installing fetches the update in the background and

prompts you before it installs. This is the default.

• Notify - only show notification when update available tells you a new version exists and leaves the

download to you.

• Manual - never check automatically turns off the automatic check. Use Check now when you want to

look.
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Set how often LanSend checks

Check frequency controls the automatic check: On startup, Daily, Weekly, or Monthly. The default is

Weekly. This setting has no effect in Manual mode, which never checks on its own.

Every download is verified for authenticity and integrity before it installs, so you can let the update run

without inspecting the file yourself.

See also

• Updates preferences

• Registering LanSend

• LanSend

Registering LanSend

Registering LanSend activates your license on this computer. You buy a key and enter it from the Help

menu.

Buy a license

Open Help > Get license key to go to the order page. Pick the license that fits how you use LanSend:

• Business is licensed per machine, so order one license for each computer that runs LanSend.

• Corporate covers a whole organization, with unlimited installations and technicians across departments

and sites.

You can also buy a LanSend license directly from the website.

Enter your key

Once you have a key, open Help > Enter license key to open the Register LanSend dialog. Type the

name the license is issued to in Licensed to, paste the key into License key, and click OK. LanSend saves

the license on this computer.

https://lizardsystems.com/lansend/
https://lizardsystems.com/purchase/lansend/
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A LanSend license key begins with the prefix LK1-LNS-, so you can tell it apart from keys for other

products.

See also

• Checking for updates

• LanSend
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Tools

The Tools menu runs an external command against the computer you have selected in the list, filling in

details like its name or IP address for you. It puts the utilities you reach for often, a ping, a PowerShell

session, a remote desktop connection, one click away from inside LanSend.

Run a tool

Select a computer in the list, open the Tools menu, and pick a tool from its category. LanSend launches the

command for that machine, substituting the computer's details where the tool calls for them. The same

variables as the rest of LanSend apply, including %computer_name% and %computer_ip%, so one tool

works against whatever machine you have selected.

LanSend ships with a large default set, sorted into twelve categories: Network Diagnostics,

Administrative Tools, PowerShell Remote, System Monitoring, Remote Desktop Services, Security &

Audit, System Tools, Network Shares, Sysinternals Suite, Advanced Diagnostics, Update

Management, and Performance Management.

Some tools need their groundwork in place on the target: PowerShell Remote needs WinRM enabled, the

Sysinternals Suite tools need the Sysinternals utilities on your PATH, and any tool that reaches a remote

machine needs network access and the right permissions.

Manage your tools

Below the categories, the Tools menu has four commands:

• Import tools adds tools from a file.
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• Export tools writes your tools to a file to share or back up.

• Reset to defaults restores the default categories and tools.

• Manage tools opens the tree where you build and arrange them.

In Manage tools, the buttons to the right of the tree are Add category, Add item, Edit, Remove, and Up /

Down to reorder. Editing a tool opens the Edit tool dialog (it reads Add tool for a new one), with these

fields:

• Tool name is the label shown in the menu.

• Command type is Standard command, Shut down command, or Send message command.

• Program name is the executable or command to run.

• Shell operation is how it launches: Open, Run as Administrator, Print, Explore, or Edit.

• Parameters (optional) is the argument template, where you put variables such as %computer_name%

and %computer_ip%.

• Working directory (optional) sets the folder the command runs in.

• Icon picks the menu icon.

See also

• The computer list
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• The main window

• LanSend
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